Two questions regarding the Windows Japanese IME

Index » General discussion

 
nicjsb Member
From: USA Registered: 2008-09-04 Posts: 16

1. It always starts off in direct input, so I always have to switch it to Hiragana before I can start typing stuff. Is there a keyboard shortcut that will switch between those various types of input?

2. Is there a way to always make something Katakana (while in Hiragana mode?) It's very frustrating when it only makes part of a word Katakana, and the rest into some Kanji I don't want. Once again, is there a keyboard shortcut to switch to Katakana mode, or do I have to manually select it?

pazustep Member
From: Brazil Registered: 2007-04-09 Posts: 30 Website

nicjsb wrote:

1. It always starts off in direct input, so I always have to switch it to Hiragana before I can start typing stuff. Is there a keyboard shortcut that will switch between those various types of input?

Yes, ALT+` (backquote, the key to the left of 1) switches between Direct Input/Hiragana.

nicjspb wrote:

2. Is there a way to always make something Katakana (while in Hiragana mode?) It's very frustrating when it only makes part of a word Katakana, and the rest into some Kanji I don't want. Once again, is there a keyboard shortcut to switch to Katakana mode, or do I have to manually select it?

F6 converts the current input to hiragana.
F7 converts the current input to full width katakana
F8 converts the current input to half width katakana.
F9 converts the current input to full width romaji.
F10 converts the current input to half width romaji.

For example, type るーすりーふ and press F7, and it will be converted to ルースリーフ. Now press F8 and it will turn into ルースリーフ. F9 will make it into ru-suri-fu. F10 will finally make it just ru-suri-fu.

There are other shortcuts, but these are the most useful, I think. If you want to see all shortcuts, right click on the language bar, select settings, then select Properties for Japanese IME. From there, go to Editing, and click the "Advanced" button near "Key Template".

Last edited by pazustep (2008 September 07, 10:06 am)

Zarxrax Member
From: North Carolina Registered: 2008-03-24 Posts: 945

A little trick that I do, is since I hate having to press combinations of different keys together (or even worse, use my mouse), I use the key settings to bind "IME On/Off" to my F12 key. I then remove my English input method altogether. Now whenever I want to switch between typing english or japanese, I just hit F12. I can even turn my language bar off altogether, because I never use it and get annoyed by seeing it there.

Advertising (register and sign in to hide this)
JapanesePod101 Sponsor
 
mentat_kgs Member
From: Brasil Registered: 2008-04-18 Posts: 1671 Website

Tks pazustep. This post was incredibly worthful.

By the way, is there how to use an alternate layout with microsoft IME?
I use dvorak keyboard and it is very anoying to switch back to qwerty just for the IME.

Last edited by mentat_kgs (2008 September 07, 10:23 am)

pazustep Member
From: Brazil Registered: 2007-04-09 Posts: 30 Website

mentat_kgs wrote:

By the way, is there how to use an alternate layout with microsoft IME?
I use dvorak keyboard and it is very anoying to switch back to qwerty just for the IME.

And I was thinking I was the only guy in South America using the dvorak layout...

Brace yourself, this one is tricky. I hope you're comfortable with editing the registry.

1. Open regedit
2. Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Keyboard Layouts\E0010411
3. This should be the Japanese IME keyboard layout entry in the registry. Confirm this key has a value "Layout Text" set to "Japanese MS-IME 2002" or something like that.
4. Change the "Layout File" value to "KBDDV.DLL"
5. Reboot

Edit: In Windows Vista, the E0010411 key doesn't exist. Instead, you should navigate to a key in the same path, but ending in 00000411. This is the "Japanese" keyboard layout entry.

Edit 2: This same trick may be used for layouts other than Dvorak. You just need to figure out the DLL for the layout you want to use, and replace the "Layout File" value in and E0010411 (for Windows XP) or 00000411 (for Windos Vista) with it. For example, use KBDSW.DLL for a Swedish keyboard layout, or COLEMAK.DLL for the Colemak layout. Read the rest of this thread for details.

This is a global setting, so it might not be a good idea if you're sharing your machine with other people who also use the Japanese IME. But what are the odds anyway?

BTW, I have created a keyboard layout for dvorak with dead keys (for typing Portuguese). If you're interested, you can find it here:

http://pazu.com.br/dav/idvorak.rar (Windows XP)
http://pazu.com.br/dav/idvorak-vista.rar (Windows Vista)

I've created this for my own use, and never tested in computers other than those I own. So, no guarantees.

Last edited by pazustep (2008 September 08, 8:27 am)

mentat_kgs Member
From: Brasil Registered: 2008-04-18 Posts: 1671 Website

Yo pazustep, what a coincidence!

I'll check this stuff you got, but I like the us dvorak layout a lot.

But I have ~10 friends already using dvorak. One more in process of switching.

nicjsb Member
From: USA Registered: 2008-09-04 Posts: 16

No way... Other people who use alternate keyboard layouts?!?

I personally use Colemak: http://colemak.com/

I use Portable Keyboard Layout also: http://sourceforge.net/projects/pkl/

This way, I can use Colemak on public computers. It's also good for use at home, since you can use it to type in Colemak/Dvorak in Japanese. I hope this helps.

mentat_kgs Member
From: Brasil Registered: 2008-04-18 Posts: 1671 Website

Tks again.

I'm now using japanese IME only. Just pressing alt+` to switch layout is so nice!

nicjsb, this pkl tool seems great. I've just tested it and it is very charming. Sadly I'm not interested in the colemak keyboard and I saw no simple way to change it to dvorak.

Tobberoth Member
From: Sweden Registered: 2008-08-25 Posts: 3364

Personally I would love to use Japanese IME only, but my keyboard is Swedish and I often write in Swedish so I have to keep using the language bar sad I sure wish it was possible to remove Direct Input since I ALWAYS want to write in hiragana when I change my language bar to japanese.

mentat_kgs Member
From: Brasil Registered: 2008-04-18 Posts: 1671 Website

Tobberoth, I think you can do that with pazu's register hack.

pazustep Member
From: Brazil Registered: 2007-04-09 Posts: 30 Website

@Tobberoth: mentat_kgs might be right. I have no idea about how the Swedish layout looks like, but in theory you can follow my registry hack above, using KBDSW.DLL instead of KBDDV.DLL.

The only problem I've found with this hack so far is that if the backquote key is a deadkey in the new layout, the ALT+` shortcut doesn't work.

Erubey Member
From: Escondido California Registered: 2008-01-14 Posts: 162

Zarxrax wrote:

A little trick that I do, is since I hate having to press combinations of different keys together (or even worse, use my mouse), I use the key settings

How do I do this? I'm tired of clicking the EN button. Or worse when it glitches up for some reason.

Tobberoth Member
From: Sweden Registered: 2008-08-25 Posts: 3364

Didn't work for me... Could it be I'm using the wrong IME or something? I changed the registry and rebooted, the direct input is still set to some other layout. I made sure I edited the correct post in the registry, and it's just like the guide sad

I went into text services and removed Japanese and added it again. It seems you can pick Japanese and then you can pick IME Standard Input, IME Natural input and simply Japanese. If I pick Japanese, I do get the swedish layout, but then that's simply it, I can't actually write in Hiragana or anything (Japanese stops showing up in the language bar). The two IME's are like normal, their direct input hasn't changed to Swedish.

Last edited by Tobberoth (2008 September 07, 4:35 pm)

Zarxrax Member
From: North Carolina Registered: 2008-03-24 Posts: 945

Erubey wrote:

How do I do this? I'm tired of clicking the EN button. Or worse when it glitches up for some reason.

First go in the regional and language options, then find the properties page for the IME. Under the first tab, click on the Advanced button. The first tab in this new window that pops up will let you set the keyboard shortcuts related to the IME. Pick one thats easy to use, and then assign the function "IME On/OFF" to it. Then hit ok and back out to the screen where it lists the IME, and set your default input as Japanese instead of english. Then click the language bar button, and uncheck the box to show the language bar on the desktop.
Sorry if thats a bit confusing, its a bit difficult to explain since there are so many different windows you have to go into.

Erubey Member
From: Escondido California Registered: 2008-01-14 Posts: 162

It worked perfectly! Thank you so much. Little things like this massively improve me wanting to write sometimes.

pazustep Member
From: Brazil Registered: 2007-04-09 Posts: 30 Website

Tobberoth wrote:

It seems you can pick Japanese and then you can pick IME Standard Input, IME Natural input and simply Japanese. If I pick Japanese, I do get the swedish layout, but then that's simply it, I can't actually write in Hiragana or anything (Japanese stops showing up in the language bar). The two IME's are like normal, their direct input hasn't changed to Swedish.

Hmm, maybe there are other keyboard layout entries? Try searching the registry for KBDJPN.DLL, and replacing them all with KBDSW.DLL. You might want to write down all changed keys, so you can revert them later if you need to.

Last edited by pazustep (2008 September 08, 7:56 am)

phauna Member
From: Tokyo Registered: 2007-12-25 Posts: 500 Website

I still have to click from Alphanumeric to Hiragana.  I've set the default to Hiragana, but it never starts as Hiragana.  It's driving me nuts.

JimmySeal Member
From: Kyoto Registered: 2006-03-28 Posts: 2279

The default only determines what mode it will be in when you swich the IME ON.  Not its initial state.

Are you literally clicking the IME to switch modes?  You know there's no need to do that.

phauna Member
From: Tokyo Registered: 2007-12-25 Posts: 500 Website

Well I've been going from Japanese IME to US keyboard, because the alphanumeric mode on the Japanese IME doesn't have apostrophes assigned to the right key, I get colons instead.  I tried changing it, but couldn't figure it out.

So no, I mean it's just an extra step, change from US keyboard to IME, then change from IME alphanumeric to IME hiragana.

Last edited by phauna (2008 September 07, 7:47 pm)

JimmySeal Member
From: Kyoto Registered: 2006-03-28 Posts: 2279

It's not an apostrophe.

pazustep wrote:

nicjsb wrote:

Is there a keyboard shortcut that will switch between those various types of input?

Yes, ALT+` (backquote, the key to the left of 1) switches between Direct Input/Hiragana.

nicjsb Member
From: USA Registered: 2008-09-04 Posts: 16

I put a Dvorak layout for pkl on sendspace: http://www.sendspace.com/file/uvmcz0

Unrar to the "layouts" folder, and change the layout to "dvorak" in the pkl.ini file.

Enjoy!

phauna Member
From: Tokyo Registered: 2007-12-25 Posts: 500 Website

Everyone uses it for an apostrophe.  ' on my IME becomes :  Also the brackets are all messed up.  I suppose it's using a Japanese keyboard layout, even though I've got it set to US.

Last edited by phauna (2008 September 07, 10:47 pm)

JimmySeal Member
From: Kyoto Registered: 2006-03-28 Posts: 2279

phauna wrote:

Everyone uses it for an apostrophe.

Everyone uses what for an apostrophe?

Nukemarine Member
From: 神奈川 Registered: 2007-07-15 Posts: 2347

pazustep wrote:

mentat_kgs wrote:

By the way, is there how to use an alternate layout with microsoft IME?
I use dvorak keyboard and it is very anoying to switch back to qwerty just for the IME.

And I was thinking I was the only guy in South America using the dvorak layout...

Brace yourself, this one is tricky. I hope you're comfortable with editing the registry.

1. Open regedit
2. Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Keyboard Layouts\00000411
3. This should be the Japanese keyboard layout entry in the registry. Confirm this key has a value "Layout Text" set to "Japanese".
4. Change the "Layout File" value to "KBDDV.DLL"
5. Reboot

This is a global setting, so it might not be a good idea if you're sharing your machine with other people who also use the Japanese IME. But what are the odds anyway?

Ok, you are officially the man (for today at least).  日の男一杯! (which I probably got wrong).

For those that switch alot: I use English Keyboard (Dvorak) for Romaji and English with an Alt + L. Shift to bring up Japanese IME w/ Hiragana as the default. The only problem I had was having to use QWERTY layout for Japanese. In my opinion, Dvorak was almost made for Japanese input (aside for P, K, Y keys being on the vowel side). So again, thanks for the hack.

Tobberoth Member
From: Sweden Registered: 2008-08-25 Posts: 3364

pazustep wrote:

Tobberoth wrote:

It seems you can pick Japanese and then you can pick IME Standard Input, IME Natural input and simply Japanese. If I pick Japanese, I do get the swedish layout, but then that's simply it, I can't actually write in Hiragana or anything (Japanese stops showing up in the language bar). The two IME's are like normal, their direct input hasn't changed to Swedish.

Hmm, maybe there are other keyboard layout entries? Try searching the registry for KDBJPN.DLL, and replacing them all with KDBSW.DLL. You might want to write down all changed keys, so you can revert them later if you need to.

I tried this and I found E00010411 also used KBDJPN.DLL (It's Windows IME Standard japanese or something) and I changed this according to your post... restarted windows... BAM, no language bar. I was like great, it messed up the language bar. Went into the language bar settings and it turned out, I can't use japanese at all anymore, windows won't recognize it. Then I realized... you misspelled the DLLs in your post. So I change it again, reboot the computer and.. WOOT.

It works perfectly big_smile Thanks so much, finally no more clicking all over the keyboard.