Back

Using the Japanese IME

#26
Another IME quirk that I just discovered: if you type numbers using the number keypad to the right, then half-width characters are inputted. If you use the numbers above QWERTY then full-width characters are used instead.
Reply
#27
Does anyone know how to get the dot that separates katakana words?
Reply
#28
its the / key
Reply
(March 20-31) All Access Pass: 25% OFF Basic, Premium & Premium PLUS! 
Coupon: ALLACCESS2017
JapanesePod101
#29
Thora Wrote:Is it possible to rename this thread "Japanese IME"?
Done and stickied.
Reply
#30
Question: how do you type ○○? This is the most common way to write a blank in Japanese, isn't it? For instance, you would give the sentence pattern "I like _____" as 「○○が好きだ」, right?

I know you can type "maru" to get a single ○, but it could be cumbersome if you want to type a lot of them.

- Kef
Reply
#31
http://thejapanesepage.com/forum/viewtop...=6&t=12614

I found this thread on TJP forums to be useful. I posted the link as I'm too lazy to ask permission of the author to repost.
Reply
#32
I just installed the ATOK 2009 trial on my Windows pc, but (I guess) since my OS language is set to english/dutch, the menu's contain weird non-japanese characters :/ and it also doesn't seem to help my azerty/qwerty problem. I don't doubt it'll be better than the MS IME, but for me it's useless now Sad

I just don't want to fool around (yet) in the register or change the system language to Japanese, to solve that problem, since I'm still pretty new to japanese. A qwerty keyboard might help perhaps in the future...
Edited: 2009-03-25, 2:29 am
Reply
#33
I'm currently using SCIM on ubuntu, but it's far from flawless... I think I need to research another option. Is anybody else using linux?
Reply
#34
Omnistegan Wrote:I'm currently using SCIM on ubuntu, but it's far from flawless... I think I need to research another option. Is anybody else using linux?
Yeah and SCIM is without a doubt the best option.
Reply
#35
Tobberoth Wrote:
Omnistegan Wrote:I'm currently using SCIM on ubuntu, but it's far from flawless... I think I need to research another option. Is anybody else using linux?
Yeah and SCIM is without a doubt the best option.
I've just noticed that they do sell ATOK for linux.
http://www.justsystems.com/jp/products/atok_linux/
Not exactly cheap though.
Reply
#36
I'm fine with SCIM, but I really miss having my hand-writing pad. Sure, there's one online, but I can't just click twice and have it instantly anymore... and the one online isn't really as good.

:: sigh ::
Reply
#37
sethg Wrote:I'm fine with SCIM, but I really miss having my hand-writing pad.
Just install it then. scim-tomoe uses the tomoe engine from http://tomoe.sourceforge.jp/cgi-bin/en/blog/index.rb.

Omnistegan Wrote:I've just noticed that they do sell ATOK for linux. Not exactly cheap though.
Last time I checked you could get a 100% discount by downloading it from Winny or Share.
Reply
#38
guys guys guys HALP

Okay so I've been using the Japanese IME for a while now, right? And there have been a few times where it's switched to the whole direct kana input -- where Q becomes た, W becomes て, etc. I've never done this on purpose nor known how to do it, and it always switches itself back after an hour or so. Recently, however, it's switched to the direct kana input, and it hasn't switched back after about three or so days and it's driving me insane. So how do I do it?

I've tried rebooting, modifying a bunch of settings THEN rebooting, amongst other obviously-futile-but-I'm-desperate-and-I'll-try-ANYTHING stuff. I've looked it up all over the internet and found plenty of sources of people asking the same question but no one ever answers, not even with an "i dunno". But if anyone here knows, PLEASE, tell me. Inputting sentences is taking absolutely forever since I'm having to learn an entirely new keyboard layout and ughhh I don't LIKE IT.

Using Windows XP, and have both the regular IME and the "Natural Input" thing installed (though I don't know the difference between the two).
Reply
#39
Click JP/EN -->Show the Language Bar. On the right hand side, click KANA (under the CAPS) to toggle between kana input and direct input.

Also, in Properties-->General -->Input method, you can select either romaji or kana.
Reply
#40
Thora Wrote:Also, in Properties-->General -->Input method, you can select either romaji or kana.
Ah, yeah, that's what I was wanting. Looking back over my post, I guess I was rathe ambiguous. Anyway, THANK YOU VERY MUCH. This is exactly what I needed and now life is so much simpler. :') You're a great help.
Reply
#41
Using Microsoft IME, how do you type the Japanese angular bracemarks/parenthesis usually used to quote a word or a phrase? Does anybody know the keys for other typical Japanese punctuation marks, or a web page summarizing those?

By the way, I'm using an Azerty keyboard.
Reply
#42
It's the [] buttons for the quote marks.

「」 『』 【】 [] 〔〕 () {} () 〈〉 《》 <> ≪≫
Reply
#43
Sorry but I don't understand, what do you mean by buttons? How do you write those three ones which I copied and pasted from your message: 「」 『』 【】
What keys do you type in on the keyboard (mine is an Azerty) and in what mode? Hiragana should input mode should work?

Second question: how do I set my Japanese IME to be on the Hiragana INPUT mode by defaut. I went to the toolbar Parameters and Properties and found an option to do that, but it does work. The IME keeps Half-width Alphanumeric as its defaut Input mode.
Edited: 2009-08-12, 1:46 am
Reply
#44
Anyone regarding my 2 issues above? Any people using an Azerty keyboard here?
How do I type in the 「」 『』 【】signs?
Reply
#45
YogaSpirit Wrote:Second question: how do I set my Japanese IME to be on the Hiragana INPUT mode by defaut. I went to the toolbar Parameters and Properties and found an option to do that, but it does work. The IME keeps Half-width Alphanumeric as its defaut Input mode.
Unfortunately, you can't. It's the biggest problem with the windows IME IMO.
Reply
#46
OK, at least I now know I can't. Thanks.
And what typing the 「」 『』 【】signs with an Azerty keyboard?
Reply
#47
On the Azerty keyboard it looks like [ and ] are located on the numbers row and there are 3 or more symbols per key. So perhaps you need to hit a function/shift/alt type button as well?

Assuming IME works with Azerty the same way as with Qwerty, try typing those keys in Hiragana mode and hitting the space bar repeatedly to scroll through the various bracket styles.

btw someone at the anki forum has given you info and instructions on mapping your own key.

fyi, here's an old forum thread on Azerty IME issues: http://www.forumjapon.com/forum/viewtopic.php?t=210. (French is OK I presume) They discuss changing the keyboard layout in the regedit to Azerty, but it sounds like you are not having problems with the other letter keys.
Edited: 2009-08-15, 1:02 pm
Reply
#48
WolfErrant Wrote:
JimmySeal Wrote:Not sure what you mean by straightforward. thi = てぃ doesn't seem straightforward or obvious to me, and having a consistent key for small characters seems, conversely, very straightforward.
I agree it's not obvious or even logical, but for me it beats "te-li". Maybe I'm wrong about this but ティ in my head sounds like "ti" not "te followed by little i". I go with the nearest approximation. I know I can type the various characters with various codes. I use "ltu" or "ltsu" whenever I need っ by itself. That's not a problem. But "thi", imperfect approximation that it is, flows better, just as for しゃ, "sha" seems to me faster than typing "shi-lya" or "si-xya" or whatever purely systematic variant.

I think there are two approaches, really. Either you follow a consistent, systematic method in which し is "si" or you try to approximate the actual sound, and use "shi". Both methods are valid, but the second seems, to me, more natural. Maybe I'm wrong about this and it hinders my pronunciation. I'm open to comments about that. Nonetheless I use both when needed. "du" for づ falls in the first category. "thi" for ティ seems ok for the second one. In the end, though, it's just a matter of being used to it so you're not slowed down when typing. Whatever works for you!
Don't know if someone responded to you yet or not, but in Mac you can set it to Romaji and HOLD "shift, control, ;" (without the " ") to get to English, "shift, control, j" to get to Hiragana, and "shift, control, k" to get to Katakana. Hope this helps!

PS - Under my language and text settings, I have the Kotoeri keyboard checked, with Hiragana, Katakana and Romaji checked. Full-width Romaji and half-width Katakana are not checked.
Reply
#49
If I have a kana sentence and decide I want to kanjify some of the words is there a way to do that in IME without retyping the word? I was hoping I could highlight the kana word, press a key stroke and it would be as if I typed it and pressed space.
Reply
#50
Wrenn Wrote:If I have a kana sentence and decide I want to kanjify some of the words is there a way to do that in IME without retyping the word? I was hoping I could highlight the kana word, press a key stroke and it would be as if I typed it and pressed space.
I'm not sure about you, but I have a Japanese keyboard. All I do is highlight the text I want to change and press the 変換 button.
Reply